ZTE Open用ROMがBuildできない!

config.sh自体は問題なくできるのですが、./build.shを実行すると以下のエラーが。。。

root@v157-7-152-94:/opt/B2G# ./build.sh

============================================
PLATFORM_VERSION_CODENAME=AOSP
PLATFORM_VERSION=4.0.4.0.4.0.4
TARGET_PRODUCT=full_inari
TARGET_BUILD_VARIANT=eng
TARGET_BUILD_TYPE=release
TARGET_BUILD_APPS=
TARGET_ARCH=arm
TARGET_ARCH_VARIANT=armv7-a-neon
HOST_ARCH=x86
HOST_OS=linux
HOST_OS_EXTRA=Linux-3.8.0-32-generic-x86_64-with-Ubuntu-13.04-raring
HOST_BUILD_TYPE=release
BUILD_ID=OPENMASTER
OUT_DIR=out
============================================

Blob setup script has changed, re-running
Backing up system partition to backup-inari
error: device not found
Pulling files from ../../../backup-inari
cat: ../../../backup-inari/system/build.prop: そのようなファイルやディレクトリはありません
Found firmware with build ID
Pulling “libOmxAacDec.so”
cp: `../../../backup-inari/system/lib/libOmxAacDec.so’ を stat できません: その ようなファイルやディレクトリはありません
Failed to pull libOmxAacDec.so. Giving up.

> Build failed! <

Build with |./build.sh -j1| for better messages
If all else fails, use |rm -rf objdir-gecko| to clobber gecko and |rm -rf out| to clobber everything else.

 

いろいろと情報を見てみていますがこれだ!というものが見つからず。

google+にあるサークルの情報を見ても解決できず。。。

 

いったい何が原因なんでしょうか。。。

そもそもなんで

cat: ../../../backup-inari/system/build.prop: そのようなファイルやディレクトリはありません

が出るのでしょうか。。。

誰かわかる方教えてください。

ZTE Open用ROMがBuildできない!」への2件のフィードバック

  1. I am having the same problem did you ever get around this? Do you have an inari 1.4 build in Japanese? I cannot create

    • How do you do.
      English is poor so mapeer in English translation.
      When the terminal does not recognize USB devices when leaving this problem to get.
      So please provide a physical terminal. Or you could avoid to build the virtual environments on Oracle VirtualBox, etc.

      初めまして。
      英語が苦手なので機械翻訳の英語で書かせてもらいます。
      この問題が出るときはUSBデバイスに端末が認識しない時に出ます。
      なので物理的な端末を用意するか、VirtualBoxなどで仮想環境を構築することで回避できました。

コメントを残す